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Excel - Basic operations

Introduction

Excel is a spreadsheet. Its role is the creation and the analysis of decision-making
models. Every document, or file, consists of several worksheets containing 256
columns (named A to IV) and of 65536 lines filled with cells in witch you can
enter either text, numbers or formulas. Every cell of the document has a unique
address. It's determined by the place where it's located in the spreadsheet. For
example, the very first cell in the upper left corner of every first sheet meets
itself in the column A on the first line. So the address that consists by its position
with regard to columns and in lines is called A1. It's at the junction of column A
and line 1. The cell address just to its right is B1 and so on. Also, every cell can
contain up to 65 000 characters.

These cells are all on the first worksheet named Sheet1. You can have up to 100
worksheet in a single spreadsheet file. That will allow you to make "in depth"
calculations. That's more than enough room to create your own models. But
sometimes, it's useful to get some numbers that are in other spreadsheet files.
Excel can help you link to those files too.

Moving inside the spreadsheet

There are several ways to move inside an Excel spreadsheet. You can always click
on the worksheet and on the cell that you need. Here is the list of keys that you
can use to move.

Blocks

There will be times when you will want to select several cells at one time so to be
able to change the presentation or to create charts or to take advantage of the

Cursors To move to a cell towards the left, right, up or down.

Enter
To accept the text, the number or the formula that was
entered in the cell.

Tab
Moves the cursor a cell to the cell on the right of the
active cell.

Shift + Tab Moves the cursor a cell to the left of the active cell.

End + cursor
Or
Ctrl + cursor

To move at the end of a series of filled cells, with some
content, or a series of empty cells.

PageUp and PageDn To move a screen up or down.

Alt + PageUp and Alt
+ PageDn

To move of one screen to the left or to the right.

Ctrl + PageUp and
Ctrl + PageDn

To move to the previous or following worksheet.

Ctrl + Home To return to the upper left corner of the current
worksheet.

Ctrl + End
To move in the last cell containing text, a number or a
formula.

F5 or Ctrl + T To move directly to any cell of the file.
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other possibilities in Excel. The software offers you at least three ways to select a
range of cells.

But before starting, it's necessary to pay attention to the format of the cursor.
The cursor changes format according to the place where it's located on the
worksheet on even inside a cell. To select cells, the cursor must have the format

of a big white "+" like this . You can't make a block when the pointer is in the

format of an arrow . However, you can move a range of cells using that format.
Place the pointer on the border of the cell or of a range of cells. Press and hold
the left mouse button and move it to it's new location. You can also copy the
content of a cell if you place the pointer on the dot at the button right corner of
the active cell. The pointer changes to the format of a thin black "+". Using this
format, you can copy the contents of the cell or the range of cells vertically or
horizontally. So, before selecting a range of cells, always make sure that the

cursor is in this format .

1-Use the mouse.

To select a range of cells by using the mouse.

Place the cursor over the first cell of your block.
Press and hold the left mouse button, move the cursor up to the last cell of

your block.
Release the mouse button.

This is practical when the range of cells is relatively small. But what to do when
you need to make a range of cells that's bigger than a screen? It's in this
situation that using the mouse with the Shift key is more practical.

2-Use the Shift key.

Place the cursor over the first cell of your block.
Press the left mouse button.
Move the cursor over the last cell of your block.
Press and hold the Shift key and click the last cell of the block.

By doing a block this way, you don't have to keep a finger on the mouse button.
It avoids overshooting the width of the block that you wanted that would force
you to go back and fourth until you select the right size.

There is a last method that you should know. Both first possibilities offer you the
possibility to make a continuous block. All the cells between both extremities of
the block will be selected. But what can you do when the necessary cells are not
the one next to another ? The last method demonstrates how you can make
many blocks of cells that are located everywhere in the worksheet.

3-Use the Ctrl key.

Make your first range of cells by using the mouse or with the Shift key.
Press and hold the Ctrl key and make your second range of cells.
If you need the other blocks of cells, keep your finger on the Ctrl key and use

the mouse to make as many blocks as you need.

This last technique is very advantageous when you have blocks of cells that are
distant from one to another. You can use it for example to select blocks that will
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be the source for a chart. But, it that last case, every block must represent at
least a series of data for the chart, not just a lonely cell.

Data entry

There are three types of data that you can enter into a cell : text, numbers and
formulas. The other objects, such as charts, drawings and maps, "float" over cells
They don't affect the cells under it. To demonstrate the many way of entering
your data, follow the following exercise:

Open Excel with a new worksheet.
Click on the A1 cell.
Enter 1 and press the Enter key.

The active cell moved to the A2 cell that's directly below A1.

Enter the text following "To the right" and press the Tab key or Tabulation
key (next to the the Q key to the left of on the first row of keys).

The active cell moved to the right of the last cell which is B2. The combination of
the Shift and Tab keys would move the active cell back to the left.

Enter the formula =A1+5 and press the down cursor on your keyboard.

You can also enter data and use the cursors to quickly pass to another cell and
enter more data. The active cell should be the B3 cell.

Place the cursor on the formula bar.

Enter 4 and press the button or press the Enter key.

As just you discovered, it's possible to enter the contents of a cell by using the
Enter, Tab and cursors keys and the formula bar.

Formulas

One of the biggest advantages of a spreadsheet is the automation of the
calculations. By entering a formula instead of a number, it's easier to change the
model and get the wanted results faster. Formulas should be used in every time
it's possible. You use a spreadsheet to analyze and interpret the results. Leave
the task of crunching the numbers to the spreadsheet.

Every formulas begins with the +, - or = sign. An Excel functions always begin
with a =.

Ex: =a1+a2 , =sum(a1:z20) , =average(a1:z20) , =vlookup(a1,B1:c20,2)

A mistake that's often committed by beginners using an Excel functions is to
place a space between the name of the function and the first bracket. Ex: =sum
() instead of =sum(). The name of the function and it's first bracket must be
glued together: no spaces. Also, some functions need more than one parameter
or information to work properly such as the =vlookup function above. A comma is
used to separate these parameters.
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To see the list of all the Excel functions, depending on the version of Excel that
you have.

Press the down arrow beside the AutoSum button .
Select the More Functions option.

OR
From the Insert menu, select the Function option.

It's possible to make a formula that uses the contents of cells that are in a
different worksheet or even a different file! To do this, you must specify the name
of the worksheet with the cell address. An exclamation point (!) is used to
separate the name of the worksheet from the cell address.

Ex: =a1+sheet2!A1 , =sum(sheet1!A1:sheet3!A1)

To really take advantage of a spreadsheet, you must be able to use numbers
coming from other worksheets and even from other files. The next part consists
in explaining how to reach the contents of cells in other worksheets and then
from other spreadsheets. If the file does not contain at least three worksheets,
you can add them by using from the Insert menu the Worksheet option.

Numbers from another worksheet

From the first worksheet, enter 100 in the A1 cell.
Click on the tab of the second worksheet.

OR
Press the Ctrl and the PgDn (Page Down) keys.

In this worksheet, enter 200 in the A1 cell.

And now for the formula. It consists in adding the contents of the A1 cells from
the first two worksheets of the file into the third worksheet.

Click on the tab of the third worksheet.
In the A1 cell, enter the = sign.

This is the start of the formula. It's now necessary to select the needed cells in
the formula.

Click on the tab of the first worksheet (Sheet1).
From the first worksheet, Click on the A1 cell.
Press the key +.
Click on the tab of the second worksheet (Sheet2).
On this worksheet, Click on the A1 cell.
Press the Enter key.

OR
In the A1 cell of the third worksheet, enter the following formula: =sheet1!

A1+sheet2! A1.

The formula is complete. The result should be 300. In fact, to reach any cell of
the file that's not on the present worksheet, you must first write the name of the
worksheet followed by the exclamation mark and the then address of the cell. Ex:
=Sheet1! A1. There is another way of arriving at the same result.
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From the third worksheet, place the cursor in the A2 cell.
In the A2 cell, enter the beginning of the formula =sum(
Click on the tab of the first worksheet (Sheet1).
Click on the A1 cell.
Press and hold the Shift key, click the tab of the second worksheet.
To end the formula, close the bracket ) and press the Enter key.

OR
Enter the following formula: =sum(sheet1:sheet2! A1).

To see if the formula works, change the value of the A1 cell of the first
worksheet from 100 to 300.

The new result of the A1 and A2 cells of the third worksheet should be 500.

All the functions can be also accomplished in "3D". That is by using the content of
cells of other worksheets of the file.

Numbers from another worksheet

Imagine the possibilities if you could also use numbers coming from the other
files! It's possible. This exercise demonstrates how to do it.

Open a new file.
Enter 100 the A1 cell.
Save the file under the name test1.xls.
Do not close the file.

The content of the first file is completed. The second file will come to look for this
number in a few moments. It's easier to carry out this operation when both files
are opened. Excel can open up to 99 files at the same time. To pass from a file to
another, go to the Window menu and to choose the required file.

From the File menu, select the New option.
From the Task pane, select the Blank workbook option.
Press the OK button.

OR

From the standard toolbar, press the button.
Place the cursor in the A1cell.
Press the key =.

From the Window menu, select the Test1 file.
OR

For those using Excel 2000 or a later version, click on the Test1 file on the
taskbar at the bottom of the screen.

Click on the cell that you need.

For this exercise, select the A1 cell.
Press the Enter key.

OR

Press the button of the formula bar.
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The formula should be =[ test1.xls ]Sheet1!$A$1.The name of the file is
between brackets, followed by the name of the worksheet, an exclamation mark
and the cell address.

Save the file under the name Test2.xls.
Close the Test1.xls and test2.xls files.
Open once again the Test2.xls file.

Every time you'll open this file, it's going to ask you is you wish to verify and
update the references of the other files. For this example, it's about the contents
of the Test1.xls file. To update the file, you must press the Yes button. Otherwise,
the file will use the same data from the last update.

You must also pay attention where you put the "linked" file. If you delete it, or
move it or rename the reference file, Excel will not be able to find it.

If you moved or renamed the file, you will have to indicate to Excel the new
location or the new name of the file. After you selected to correct file, press the
OK button to update the link.
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You'll find more information about some Excel functions on the chapter on
functions and formulas on this site.

Edit a cell's content

Instead of having to rewrite the contents of a cell, you can change it's contents to
correct "typos" or the formula. There are three ways to change a cell's content.

You must first place the cursor in the cell to be changed. Then,

Press the F2 key.
OR

Double-click in the cell to be modified
OR

Click in the formula bar to change the contents.

The worksheets

It's on the worksheets that you can write down the text, the numbers, the
formulas and the other elements of our model. It's possible that you want to
distribute your model on to several worksheets. Every worksheet has a name that
you will find at the bottom of the screen. By default, they are called Sheet1 ,
Sheet2 . This next part is going you to demonstrate how to add worksheets, to
rename them, to move them and even to copy a complete worksheet.

Add a worksheet

Even by placing your numbers on the worksheets that are shown, it's very
possible that you need more worksheets. A spreadsheet can contain up to 100
worksheets.

From the Insert menu, select the Sheet option.
OR

Place the cursor on the tab of one of the worksheets.
Press the right mouse button.
From the context menu, select the Insert option.
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Delete a worksheet

For aesthetic needs or any other reason, it's always possible to remove a
worksheet of the file.

Place the cursor on the worksheet that you want to remove.
From the Edit menu, select the Delete a sheet option.
Confirm the deletion by pressing on the OK button.

Rename a worksheet

It's much more practical to help you to find of the information you need when the
names of worksheets are more familiar to you such as "Budget" or "Forecasts"
instead of Sheet1. There are various ways to rename a worksheet.

From the Format menu, select the options Sheet and Rename.
OR

Double-click on the tab of the worksheet.
OR

Place the cursor over the tab of the worksheet.
Press on the right mouse button
From the context menu, select the Rename option.

Move a worksheet

Excel offers you also the possibility to quickly move a worksheet in your
spreadsheet. You can move them between other worksheets.

Place the cursor over the tab of the worksheet to be moved.
Press and hold the left mouse button, move the tab towards the left or the right

according to your needs.

A small black arrow will indicate you the point of insertion if you Release the
mouse button at this moment.

Copy a worksheet

Excel allows you also to copy all the contents of a working sheet with a variation
of the last technique.

Place the cursor over the tab of the worksheet to be copied.
While pressing on the Ctrl key and on the left mouse button, move the new

worksheet in the wished place.

Copy the contents without creating a new worksheet

Click the gray box of the upper left corner of the worksheet; between the " A "
and " 1 " headers.

From the Edit menu, select the Copy option.
Place the cursor on the worksheet on that you want to copy the data.
Place the cursor in the cell where you want to insert the data.
From the Edit menu, select the Paste option.
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Split the screen

This option splits the screen into several windows. This is very practical when you
want to compare data that's distant from one to another. For example, you want
to compare this month's numbers with last year's or the forecast for next year.
However, there is twelve months worth of data separates the two. The next
exercise consists of showing you how to put two cells next to another by splitting
the screen.

Open a new file or place the cursor on a new worksheet.
Place the cursor in the D6 cell.
From the Windows menu, select the Split option.

The worksheet is now separated into four parts. It's also possible to separate the

screen only vertically or horizontally. Just above the vertical bar and to the

right of the horizontal bar you will find the divider bars. You can place them
in any place on the worksheet. You can also change the place any time or even to
remove them. Just place the cursor on the divider bar, press and hold the left
mouse button, and "pull" it in its new location.

Press the F6 key several times.

The F6 key serves for moving from one zone to another. If you press it several
times, you'll notice that the cursor moves in a clockwise fashion. The Shift and
F6 keys "turns" the cursor counter clockwise. Zones move in a synchronized way
as you move horizontally or vertically.

To remove the divider bars

From the Windows menu, select the Delete the dividers option.
OR

Place the cursor on the divider bar.
Press and hold the left mouse button, move the bar towards one of the borders

of the screen.
OR

Double-click on the divider bar to be removed.

Freeze a part of the screen

On a worksheet, it's important to have titles that describe the numbers. It's
important to see these titles at all times. After all, the numbers are used to
describe something. The Excel designers, as well as the other spreadsheet
programs available on the market, recognized this fact. The option to freeze part
of the screen allows you to always have certain area visible on the screen.
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Write the text in the appropriate cells.
Place the cursor in the B2 cell.
From the Window menu, select the Freeze shutters option.
Press several times the PgDn (PageDown) key.

Although you moved on the worksheet, the text that you wrote above and to the
left of the place that you fixed the shutters is always visible. To return to a
normal page.

From the Windows menu, select the Release shutters option.
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Excel - Presentation

Introduction

Generally, it's not enough to create a model with the spreadsheet. You usually
must be able to present the results to the other people; either your boss or your
client. This page is dedicated to improve the presentation of your worksheets.

Here are some options that you can carry out to improve the presentation of your
worksheets.

Change the font as well as the size and color of the text in the cells.
Add titles to each parts of the document.
Center the titles with regard to a series of cells.
Insert spaces between each of the parts of your document.

Improve the presentation of your worksheet

Often, you have to present the results of your spreadsheet to other people. There
are several possibilities to improve the presentation. Excel offers you these
options in two different ways: by using the Format toolbar or from the main menu
under the Format and Cell options.

Format toolbar

If you don't see this toolbar in the screen, make the following operations.

From the Edit menu, select the Toolbar option.
From the list of the toolbars that are available on you, select the one named

Format.

The Format toolbar groups together several possibilities.

You can change the font as well as its size. You can also put the text in bold, italic
or underlined.

You can align the text or the number in the cell to the left, the middle or to the
right side of the cell. You can also align the text on to several columns. This is
designed to align a main title over several columns. Write the text in the cell to
the leftmost of cells that you want to center. Make a block of all the cells in that
you want to center the text. The leftmost cell should be the one that contains the
text to be centered. Then press on the fourth button for the alignment, that the
one with the letter " a " and two horizontal arrows.
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You can also change the presentation of the numbers in cells. You can place the
monetary format with two decimals, or the percentage format, or group together
numbers by the thousands. You can also add or remove decimals in the
presentation. But this is only for presentation purposes. It doesn't affect the real
number in the cell. For example, if the true number of the cell is 12,4 and that
you want to present it without decimal, the number that will appear in the cell will
be 12. However Excel will use the "true" value to make any calculations. So, the
result of the cell multiplied by 5 will not be 60 (5 * 12) but really 62 (5 * 12,4).

You can also change the presentation of the cell itself. You can frame the cells,or
a group of cells, with various types of lines. You can also change the background
color and the pattern for the cell. As the last option on this toolbar, you can also
change the color of the text. It can be for one letter or the entire content of a cell.

Format of the cell

The are other ways of changing the presentation of your file. In the main menu
under the menu Format and Cell options, you will find all the options to change
the presentation, including others that are not in the Format toolbar. You'll find all
the options under the following six tabs.

Select a cell or a range of cells.
From the Format menu, select the Cell option.
If it's not already done, select the Numbers tab.
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In this window, there are six tabs that offer all the possibilities for the
presentation of cells. As you go to see, there are a lot more options than what is
available from the Format toolbar. Under the first tab you will find the options to
change the presentation of numbers. In the categories box, there are several
styles of presentation for numbers and text. You can even personalize the
presentation according to your needs. In the right part of the window, you have
options according to the style of presentation that you chose. In the image on the
left side, you can determine the number of decimals that will be shown, the
monetary symbol and the color of the number if it's negative. You can even
personalize the numbers according to your needs.

Click on the Alignment tab.
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From this window, you can adjust the adaptation of the text inside the cell. You
can paste the text on the straight or to the left or right side of the cell's border, in
the height, middle or in the bottom the cell. One of the new options allows you to
change the orientation of the text. You can also give an angle to your text! This is
interesting for titles and some descriptions. However don't exaggerate its use.

From this window, it's also possible to merge or to " defuze" cells. To merge, it's
first necessary to make a block with cells. Then, come to the window to the left to
activate the " Merge cells " option. To remove the fusion, deselect the last option.

Click on the Font tab.



Dr. RACHINI Ali – Microsoft Excel - Presentation

16 | 2 0 7

To leave this window,
you can change the
presentation of the
characters of the cell.
You can change the
font, its style, its size,
the background and
the color of the text
from the other
options.

Click on the Border tab.

From this
window, you can
determine the
outline of a cell or
of a range of
cells. You can
choose the style
of line (none,
simple, double,
thick...) and the
color of your
choice of the
right-hand side of
the window. Of
the left-hand
side, you indicate
the place you
want the line by
pressing on one
of the buttons
surrounding the
outline. You can
also click inside
the outline to fix
lines.
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Click on the Patterns tab.

Excel offers you also
the possibility of
changing the
thorough color of cells
and even to put it a
pattern. Be sure that
the text remains
always legible even
with a pattern.

Click on the Protection tab.



Dr. RACHINI Ali – Microsoft Excel - Presentation

18 | 2 0 7

This tab is very
practical when you
want to present a file
that other people may
use. It's very possible
that you don't want
them to change your
Formulas. You can
protect cells
containing your
Formulas, or even to
hide them. The
protection is made in
two stages. You
indicate to Excel the
cells that you want to
unprotect. It's the
cells that the others
will be#able use to
enter numbers or
text. All other cells
will be locked and
cannot be changed.

The second stage consists in protecting the worksheet or all the spreadsheet.
When you'll have to unprotect the appropriate cells:

From the Tools menu, select the Protection option.

Excel offers you the choice to protect the worksheet, the spreadsheet ( the file) or
to be able to share the document with the other people.

For the moment, select the worksheet option.
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You can determine the elements of the
sheet that you want to be protected.
You can also put in a password to
protect the worksheet or the file. It's
however not compulsory. You can
leave the empty box and the sheet will
be always protected until it somebody
removes the protection. Don't worry if
you put the protection and forget the
password. There are software or
macro for Excel that exists "to crack"
the password. It's going to take only a
few seconds to discover and remove
it. To find these software, use a
research site and look the words crack
or password and excel.

Be careful!
You cannot "crack" a password of a
document without having first the
permission from the owner of the file.
Otherwise, you're in big trouble!!!

Try to change the contents of a cell.

As soon as you go to try to change a value, Excel will present you the message
above. The software warns you that this worksheet is protected and that you
cannot change the contents of protected cells. For the moment, remove the
protection on the worksheet.

From the Tools menu, select the Protection option.
Select the Remove the protection of the sheet option.

Copy the presentation format

These last options offered to change all the options of the presentation. There is
however a faster way to apply presentation style to other cells. You just have to
copy an existing presentation style that's already in another cell by using the

button. The next exercise demonstrates how to use this option.
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Enter the text following in the appropriate cells.

If you don't see the toolbar with the button:

From the Edit menu, select the Toolbar option.
Of the list of the available toolbars, activate the Standard toolbar.

It's first necessary to apply a presentation style to a cell.

Place the cursor in the B1 cell.

Press the button .

It's now necessary to copy this format of presentation in the other cells of the
example.

Make sure that the active cell is the B1 cell.

It's the format of presentation of this cell that will be copied on the others.

Press the button .
Click on the C1 cell.

The format presentation style for January was copied on to February. It would
have also been easy to apply the format to a range of cells such as for every
month. The problem with this technique is that it's necessary to press the

button every time you want to copy the presentation style. This is not practical
for several blocks of cells.

The designers of Excel found an easy method to apply the same presentation
style to several blocks. The next exercise consists of applying a presentation style
to several separate cells.

Make sure that the active cell is the B1 cell.

Double-click on the button .

To click twice the button will not be enough. It's necessary that you double-
click.
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Click on the D1 cell.
Make a block with cells A3 for A5.

Press again on the button to deactivate the option.

You now see how easy it's to quickly prepare a presentation for your spreadsheet.
There is an even faster way: the automatic format.

Autoformat

You can spend a lot of time to try to improve the presentation of a file. Excel
offers you predefined formats for presentation. It's enough to apply the
presentation style of your choice to the area of cells that you want.

Select the area of your worksheet that you want to change the presentation.
From the Format menu, select the Autoformat option.

Select the format of your choice for the range of cells you selected.
Press the OK button.
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Here is what could look like your data by using one of the formats available. It
took only a moment.

Conditional format

The conditional format allows to change the presentation only when a series of
events apply. For the example below, one wants that the available quantity
changes the red when the quantity is lower than the minimal quantity. It makes
easier to notice the number and to command or to produce the others.

Enter the text and the following numbers the appropriate cells.

Note:
To be able to enter several lines of text in the same cell, you must use the Alt
and Enter keys.

Place the cursor in the A2 cell.
From the Format menu, select the Conditional Formatting option.

You must now write a condition and to choose a kind of presentation when this
condition occurs.

For the first box, leave the option to The value of the cell is.

The second box determines the kind of condition. As you notice it's very complete
list.

For the second box, select the Less than condition.
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For this condition, you want to compare it with the contents of the B2 cell.

For the third box, write in the box =B2.
OR

Press the button in at the right of the box.
Select the B2 cell.

Press the button.

It's also possible to add up to 3 conditions and to change the presentation under
different circumstances. You just need to press the Add button to add another
condition. For the moment, there are no need for another condition.

Press the OK button.

The conditional format is placed in the A2 cell. It's time to test it.

Change the number of the cell A2 to 50.

Here is the result. The number is now in red. This happens only when the number
of this cell is lower than the minimal quantity declared in B2 cell. You can add
conditions or remove them. Experiment with different numbers and think where
you could apply this option in your models.



Dr. RACHINI Ali – Microsoft Excel - Presentation

24 | 2 0 7

Excel also allows you to copy the conditional format with the button. The

relative and absolute references apply also to the conditional format. In the last
example, there is a difference between =B2 and =$B$2 when you go to copy
the format on to other cells.
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Excel - Page setup and printing

Introduction

Excel allows you to print your document as well as to bring it additional page
layout options to your presentation. You can add a header or footer to a page,
change the margins as well as several other options. This page shows how to
setup your printout as well as the options for printing. You'll then be able to
improve the presentation of your file on paper.

Page setup

The options of the page layout exist to improve the presentation of your
document on to paper. You can change the margins of sheets, add the headers
and footers and several other options that will be discussed below.

From the File menu, select the Page setup option.

Under the Page tab, you will find the first options for the presentation of the file
on to paper. In the first block, Excel asks you for the orientation of the pages to
print. The second block asks you the scale you want to print your file. It's
important when one of the columns you want to print falls on the next page
instead of the page that you would have wished. You can manually change the
scale to reduce or increase the size of your spreadsheet. You can also ask to
Excel to find automatically the best size to enter your document on to X pages in
widths and Y pages in height. At any time, you can look at the printout before
printing by pressing the review button. You can also change the type of paper
(letter size, legal, newspaper ...) as well as the quality of the printing. For
printing in the computer lab, be sure that the paper size is always " US Letter ".
The last option allows you to choose the page number that will begin the printout.
For example, the first page of your printout could be numbered page 5 and so on.
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Under the Margins tab, you can determine the margins, the width between the
border of the page and your text, for the file as well as those for the header and
the footer of the page. You can also choose to center horizontally and vertically
your worksheet on the page. You can also determine the place for the header and
the footer for the worksheet your about to print. The outline in the middle of the
window gives you an idea of the effect of these choices on the paper.
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Under the Header/Footer tab, you can determine what will be in the header and
the footer of each of the pages of the printout. If you don't want a header or
footer, select the first option, "none", from the list of the predetermined options.

Personalize the header and footer.

It's sometimes worthwhile to add a header or footer to a document. It helps to
identify the document and what it's supposed to represent. For example, a header
with the title "Monthly revenues and expenses for May 2006" says it all. The next
exercise consists in writing the name of the document, your name as well as the
date and the hour of the printout.

Under the Header/Footer tab, press the Custom Header button.

The options to personalize the header will appear as above. These are the same
options for the page footer. In the middle of the window, there is a series of
buttons with the most often used options. The section at the bottom is separated
into three boxes. The left box will contain the text that will be written on the left
side of the page. The box in the middle will contain the text that will be in the
middle of the header and so on.

Click in the left box.

Press the button to insert the name of the file.
Click in the box of the middle.
Write your first name and name.
Click in the box of the right-hand side.

Write: Date: and press the and buttons.

The current date and time and the time of the printout will appear on the right
side of the header.

Press the Enter key.

You can write many lines in a header or footer. The next part consists of adding
the page number and the total of pages in your printout.
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Write Page and press the button.

Write of and press the button.
Press the OK button.
Press the Preview button
Press the zoom button to better see the header.

The result should look like this.

This last exercise demonstrated what you can use the options, write text or to
combine both to give you a better result. It's also possible to write as many lines
as you need in the header or footer.

Press the Close button to return to the page layout options.
Click on the Sheet tab.

Under the Sheet tab, you can determine what range of cells will be printed in the
printing zone box. You can determine that area of your worksheet will be printed.
Instead of printing all the contents of a worksheet, you can choose to print only a
part of it.

The titles boxes are very practical. Often, you use the first lines and the first
columns in a worksheet to write the important titles such as: income, charges,
gross profit, net profit, a list of the months, a list of items or important accounts
etc. But these titles will not be reprinted on the second page or the following
pages unless you force Excel to make it so. This option will reprint the selected
lines and columns on to every page. Be careful not to put these lines and columns
in the printing zone. Otherwise, these are going to be printed twice on the first
page of your printout.
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You also have access to the other options to print the grid on all the pages, to
print in black or white or in "draft" mode if you wish it. It's also possible to print
the lines and columns headings (A, B, C, 1 , 2 , 3...) and even your comments.

The printing zone

Besides allowing you to print your entire spreadsheet, Excel allows you to print a
part of your worksheets. It's however necessary to determine in advance the
printing zone that you need. There are several ways to carry out this task.

From the File menu, select the Printing zone and Define options.
Make a range of cells with the area that you need to print.

OR
From the File menu, select the Page Setup option.
Select the Sheet tab.
Click in the Print area box.
Select the range of cells that you need to print.

While pressing on the Ctrl key, it's possible to you to select several zones of
printing at the same time. However, every zone will be printed on a different
page.

Printing

If you press the button, Excel will print all the contents of the worksheet
shown on the screen or according to the options that you chose in the page
layout option just covered above. You can however control some options for
printing. The next part explains these options.

From the File menu, select the Print option.
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The window offers you several options. In the first box, you can choose the type
of printer on witch your document will be printed. If you work in an office, it may
be possible that you have access to more than one printer. For example, you
could have access to a laser or and ink jet printer or even a color printer.

Excel offers you the options to print your entire document or only some pages
specified by your file. That's very practical when you need to reprint a few pages
after a correction. In the print section, Excel offers you to print the block that you
selected first or only to print the worksheet where the cursor is or to print all the
worksheets of your file that contains a number, text or a formula.

In the middle left of the window, you may choose the number of copies that Excel
will print.

Page break

The previous parts of this page showed you how to change the presentation of
the document on paper and the options for printing. But what if you wanted a
part of the document to always be at the start of a new page? Excel offers you
the possibility of putting in page breaks at any place in a worksheet. The next
part of this page demonstrates how to use page breaks.

Place the cursor in the B2 cell.
From the Insert menu, select the Page break option.

The page break will be placed above and to the left of the active cell. The dotted
lines indicate the separation between pages to be printed.

To remove a page break.

Place the cursor in the cell in the intersection of page breaks. For the exercise,
place the cursor in the B3 cell.

From the Insert menu, select the option Delete Page Break.

In that case, the vertical page break will be deleted but not the horizontal page
break. The B3 cell was only tied to the vertical page break. Any cell in the B
column, apart from B2, would have need able to delete the vertical page break.
The B2 cell could erase both vertical and horizontal page breaks.

Place the cursor in the B2 cell and delete the horizontal page break.

To insert only a vertical page break.

Click on the letter of the column that you want to insert the page break. For the
exercise, select the B column.

From the Insert menu, select the Page break option.
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The page break will be placed on the left-hand side of the selected column.

Delete the page break.

To insert a horizontal page break.

Click on the number of the line that you want to insert the page break. For the
exercise, select line 2 by pressing on the grey box with the number 2.

From the Insert menu, select the Page break option.

The page break will be placed above the selected line.

Delete the page break.

Outline of page breaks

The preview page breaks option shows to you what the document will look like on
paper. But before, you must prepare the worksheet by entering some numbers
and a page break.

Enter the number 1 in the A1 cell.
Enter the number 2 in the B2 cell.
Enter the number 3 in the C3 cell.
Enter the number 4 in the D4 cell.
Enter the number 5 in the E5 cell.
Enter the number 6 in the F6 cell.
Place the cursor in the C3 cell.
From the Insert menu, select the Page break option.
From the View menu, select the Page break preview option.

Excel gives you a message to inform you that it's possible to move the page
breaks to better answer your needs.

If you don't want to see this message anymore, click in box in the window and
press the OK button.
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Excel will show you the worksheet by indicating the contents of the pages and the
page breaks will appear. You can move the page break by placing the pointer on
them, pressing and holding the left mouse button and moving it around.

To deactivate the option and return to the normal presentation, of the View
menu, select the Normal option.
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Functions

Introduction

=Sum()
=average()
=min()
=max()
=rand()
=abs()
=round()
=roundup()
=rounddown()
=int()
=fact()
=mod()

=count()
=counta()
=countif()
=countblank()
=sumif()
=even()
=odd()
=sqrt()
=sign()
=trunc()

Functions that applies to text

=right()
=left()
=concatenate()

=nbcar()
=roman()
=text()

Functions that applies to a date or time

=now()
=today()
=year()
=month()
=day()

=workweek()
=hour()
=minute()
=second()

Insert a function

=If
=Vlookup, Hlookup

Introduction

The biggest advantage of functions is that they are ready to be used. You don't
have to recreate them or to look for them in books to find the one that you need.
Excel's help file can help you find what you need. You just need to press the F1
key to have access to it.

Be careful! This applies to all functions.
Don't leave a space between the name of the function and the first bracket like:
=sum (.... The function won't work. The correct way would be =sum(... This is a
common mistake among beginners.
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To complete the next functions, fill in the cells with numbers and text in the
appropriate cells.

The Sum function and the AutoSum button

The =sum function is very probably the one most often used functi on in Excel.
The program offers you two ways to use this function: by writing the formula or

by using the Autosum button . You can simply write the formula =sum( as
often as you wish. The character ":" must be placed between the starting cell and
the ending cell of the range of cells you want to add. For example, to find the
sum for the area between cells B1 and B3, the formula will be =sum(B1:B3). A
range of cells can include several lines and several columns.

In the B5 cell, enter the following formula: =sum( B1:b3 ).

The result should be 600.

Change one of the numbers in the B1 to B3 cells.

The new sum will be displayed in B5 cell.

There are several ways of writing a formula. You can write a formula by writing it
manually or by using the cursors or the mouse to select the proper cell that you
will need in the formula. The next three exercises are going to demonstrate how
to use these three techniques to find the sum between the B1 to B3 cells. Once
you've have mastered these techniques, you can use them for any functions and
formulas.

Place the cursor in the B5 cell.
Press the = key.

You can always start a formula with the +, - or = mathematical operators.

Press the up cursor, move it to the B1 cell.
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Please notice that there is a box around the cell that flashes. It's to reassure you
that you selected the right cell. You can't confuse it with the other cell on your
worksheet.

Press the + key.

Noice that the cursor returned to the B5 cell, where it will continue to write the
formula. As soon as you press one of the mathematical operator keys (+,-, *,/,
^) or a bracket, the cursor always returns to the cell where it's writing the
formula.

Use the up cursor to move to the B2 cell.
Press the + key.
By using the up cursor, move to the B3 cell.
Press the Enter key.

The formula is finished. The B5 cell will show the result of the formula. That's one
way to write the formula. It's an easy way to write a formula if you don't have
many cells to add up. But it may be the only way if you're using many different
mathematical operators. For example, the sum() function won't be of any use to
write this formula: =b1*(1+b2)/b3. The next exercise consists adding the same
cell using the sum() function and by selecting an area of cells using the cursors.

Place the cursor in the B5 cell.
Write the following formula: =sum(.
By using the up cursor, move the active cell in the B1 cell.
While pressing on the Shift key, use the down cursor to move to the B3 cell.

The block is selected. The Shift key allows you to select a range of cells on witch
you can do some operations. That can be from using them in a formula, changing
their presentation or even deleting their content. You can do an operation on
many cells instead of just one.

End the formula by pressing on the ")" key.
Press the Enter key.

As just demonstrated it's also possible to select an area of cells by using cursors
and the Shift key. You can have the same result by using the mouse. That's the
next exercise.

Place the cursor in the cell B5.
Write the following formula: =sum(.
By using the mouse, click on the B1 cell.
Press the left mouse button and select B1 to B3 cells.
End the formula by pressing on the ")" key.
Press the Enter key.
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This last exercise demonstrates that it's possible to select an area of cells as
much with the mouse as with the cursor keys.

The AutoSum button is much simpler. But, it has its limitations you should be
aware of.

Place the cursor in the B5 cell.

Press the button.

Excel will offer you the formula: the sum of the B1 to B4 cells or =sum(B1:b4).

To confirm the formula, press the Enter key.

But how did the function determined the right area? The AutoSum function first
looks upward to determine if there are any numbers to add up. If there are no
numbers in the two cells directly above the active cell, the AutoSum will try to
find numbers to the left of the cell.

In the example above, it does not find numbers in the B4 cell just above. But it
does find a number in the B3 cell. The function moves up the column until it finds
an empty cell. At that moment, it stops and suggests you an area
(=sum(B1:B4)).

This option is very practical. The problem is that it can stop at the wrong place. If
you have a cell that's empty from the block, the function will stop there, even if
you wanted to have the other numbers above that empty cell. Be sure that the
function selects the right area of cells before confirming by pressing on the Enter
key.

=Average(range of cells ex.: A1:D5)

Finds the average for an area or range of cells.

In the B6 cell, write the following formula: =average( B1:b3 ).

=Min(range of cells)

Finds the smallest value among an area of cells.

In the B7 cell, write the following formula: =min( B1:B3 ).

=Max(range of cells)

Finds the highest value among an area cells.

In the B8 cell, write the following formula: =max( B1:B3 ).

=Rand()

This function generates a random number between 0 and 1. It's often used during
simulations. You can change te random number by pressing the F9 key. You can
also combine this function with other to make it more useful. The next example
generates a number between 700 and 1000. The lowest possible value is 700 and
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the maximum is 1000. The difference between them is 300. You can use one of
these formulas to generate a number between 700 and 1000:
=ROUND((RAND()*300)+700,0) or =INT(RAND()*300)+700 . The function used
in combinason with =rand() will be explained later on this page.

=Abs(cell or value)

Shows the absolute value, or positive value, of any number.

number Abs(number)

25 25

-43 43

=Round(cell,number of decimals)

Allows to round a number to the decimal place of your choice. You must enter the
number, or the cell address where the number is located, and the number of
decimals you need.

Number Round(number,0) Round(number,1)

45.15 45 45.2

45.49 45 45.5

45.54 46 45.5

You can also round to the unit, to tens or the hundreds and so onby putting a
negative value on the number of decimals.

Ex.: =round(45,-1) = 50

These options also applies to the next two functions.

=Roundup(cell,number of decimals)

This function rounds up a number at the decimal place of your choice. A value will
be rounded up even if there is just a faction after the decimal of your choice.

number roundup(number,0) roundup(number,1)

45.15 46 45.2

45.49 46 45.5

45.54 46 45.6

=Rounddown(cell,number of decimals)

This function function "removes" any fraction after the decimal place of your
choice.
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number rounddown(number,0) rounddown(number,1)

45.15 45 45.1

45.49 45 45.4

45.54 45 45.5

=Int(cell)

Shows the Integer of a value. It removes all the fractions after the decimal point.

number Int(number)

25.99 25

43.55 43

=fact(number)

Shows the factorial of a number. It's very useful calculating propabilities. Ex.:
=fact(3) = 6 (1 * 2 * 3)

=mod(number,divider)

Shows what remains of a division. Ex.: =mod(13.4) = 1 .Thirdteen (13) divided
by 4 is equal to 3. It remains 1.

=count(range of cells)

Counts the number of cells with a number, not text or empty, within a selected
range of cells.

=counta(range of cells)

Counts the number of cells that have some content, that are not empty. The can
either have numbers, text or formulas.

=countif(range of cells,criteria)

Counts the number of cells that have the same content as the criteria. The next
exercise shows the number of cells that contain the number 100. The formula
entered in the B1 cell is =countif(A1:A3,100) .

Enter les numbers and formula in the appropriate cells.

Enter the number 100 in the A2 cell.
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The result of the =countif() now shows that two cells contain the number 100.
It's also possible to use this function to find if there are any other cells within a
range that have the same value. You mus t combine the =countif() with the =if()
function. The formula is =if(countif(range of cells,criteria)>1,"Double","Unique") .

Place the cursor in the B2 cell.
Enter la formule suivante: =if(countif(A1:A3,A1)>1,"Double","Unique") .

For this example, the formula checks if the number that's in the A1 cell appears
more than once within the range of A1 to A3. If that's the case, the result will
show "Double".

=sumif(range of cells,criteria)

This function adds numbers that have the same value.

Place the cursor in the B3 cell.
Enter this formula: =sumif(A1:A3,100) .

With this example, the function will add all the cells in the range that have the
number100. Since there are two cells with that number, the result will be 200.

=countblank(range of cells)

Counts the number of empty cells in the selected range of cells.

=even(number)

Shows the next even number if the number isn't already even.

number even(number)

2 2

3 4

=odd(number)
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Shows the next odd number if the number isn't already odd.

number odd(number)

3 3

4 5

=sqrt(number)

Shows the square root of a number or from the content of a cell. Ex.: =sqrt(9) =
3

=sign(number)

At times, it's useful to know not the value of a cell but it's sign. This function
shows 1 if the number is positive, 0 for 0 and -1 for a negative value. The
equivalent could be done with this formula =if(number>0,1,if(number=0,0,-1)) .

number =sign(number)

45 1

0 0

-45 -1

=trunc(number,number of decimals)

Shows the number with the number of decimals desired. It's the equivalent of the
=rounddown() function.

Functions that applies to text

Excel also has some functions that can help you get more out of the content of
text cells. Here are some examples.

=right(text,number of caracters)

Shows the n caracter from the right of a cell with text.

ex.: =right("This is an example",2) = le

=left(text,number of caracters)

Shows the number of caracters from the left of a cell with text.

Ex.: =left("This is an example",2) = Th

=concatenate(first cell,second cell)

This function allows you to group the content of many cells together even if it's as
different as text numbers dates or the result of a formula.
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Ex.: =concatenate("Ce",45) = Ce45

=len(cell or text)

Shows the number of characters in a cell. Ex: =len("abcde") = 5

=roman(number)

Converts a number to its roman equivalent. Ex.: =roman(45) = XLV

=text(number,text format)

Converts a number into text format. It will take the presentation format as any
other cell containing text. It's still possible to use the content for mathematical
operations or in formulas. Ex.: =text(45,0) = 45 but the text is placed on the left
border of the cell.

Insert a function that applies to dates or time

Excel also offers functions that allows to get information on cells containing dates
and time. These cells contain a lot of information. Here is a list of the functions of
this category that most often used.

=now()

Shows the exact time at the moment you confirmed the content of the cell. It will
also update itself every time you enter or change a value in a cell.

=today()

Shows the computer's date, whether is right or not.

=year(cell with a date)

Shows only the number for the year that's inside a date.

=month(cell with a date)

Shows the month that's inside a date. The result will always be between 1 and
12.

=day(cell with a date)

Shows the number of a day that's inside a date. The result will always be between
1 and 31.

=workweek(cell with a date)

Shows a number that represents a number for the day of the week: 1 = sunday,
2 = monday ... 7 = saturday. You can combine this function with =if() or
vlookup() to show the day of the week instead of just a number.
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=hour(cell with time)

Shows the hour that's inside a date or a time. The result will always be between 0
and 23.

=minute(cell with time)

Shows the minutes that's inside a date or a time. The result will always be
between 0 and 59.

=second(cell with time)

Shows the seconds that's inside a date or a time. The result will always be
between 0 and 59.

Insert a function

Let's take the following example. You want to know how much will be your
monthly payments if you take a 25 years mortgage at an annual rate of 6,5 %.
There is already a function in Excel to help you to find the amount.

Enter the text, the number and the following formulas in the appropriate cells.

These formulas deserve a few explanations. The rate should be that for each
payment periods and not the annual rate. To find the number of payments, it's
necessary to multiply the number of years with the number of payments made
during a year.

Place the cursor in the B6 cell.

From the Insert menu, select the Functions option.
OR

Press the button.
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The left column groups together
the functions into categories.
The right column shows the
name of the functions for that
category. Below these two
columns, there is a brief
description of the function. If
that's not enough for you, there
is help at the bottom of the
window by pressing

the button.

From the left column select the Financial category.
From the list of functions in the right column, select the PMT function.
Press the OK button.

The PMT function window of the will appear. It shows the boxes that need
information for the formula to work. The titles that are in bold (rate, number of
periods and present value) are required. The titles that are of standard size (Fv
and Type) are compulsory.

You must enter the amounts in the boxes or to indicate the function in the cell
that will find wanted amounts. For the exercise, it will be boxes B2, B3 and B1
respectively.
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You can write the cells addresses in the boxes or you can use the button at
the end of the box to select the desired cell.

For this exercise, press the button at the end of the rates box.

The function window disappears. A smaller window with only the information on
rate is shown. You must now choose the cell where the rate for the loan is
contained.

Click on the B2 cell.

Press on the '' / '' key .
Click on the B3 cell.

To end the operation and return to the function window, press the button at
the end of the box.

Use the same technique to select the cell for the number of payments and for
the amount of the mortgage.

Press the OK button.

The result of the function should be -337.60 $. To avoid the negative amount,
you can put the - (minus) sign in front of the function (-PMT (...)) or in front of
the amount of the mortgage (B1). You can now change the amounts and the rate
to better suit your needs. You'll be able to better plan the amount you need to
buy your first house. Don't forget to add to that, as a home owner, you'll have
property and school taxes to pay, maybe a water tax and home maintenance cost
that you didn't have before.



Dr. RACHINI Ali – Microsoft Excel – Functions

46 | 2 0 7

Excel offers you several other functions in different categories. Experiment with
these before needing them in your work.

These functions help you to create models that are closer to reality. The IF
function allows you to adapt the model according to different situations. For
example, is there a premium to be paid? Are there overtime hours to be paid?

=If

The =If function is very practical in a model because it gives you can adapt your
model to different situations. For example:

After a certain number of hours, the employees have a right to overtime pay.
After a certain amount of payment, the tax rate increases.
When the shop is full, there are expenses to ship and store excess inventory

elsewhere.
When a customer buys certain number of a product, he may have a right to a

discount.

The number of possibilities is infinite! The other functions, with the exception of
=Vlookup and =Hlookup, don't offer what this function can offer: a choice,
some flexibility for your model. It will give a certain result if the condition is
realized. Otherwise, another result will appear.

The =If function requires three parameters to work. The first is the condition:
what does it have to compare? The second part is what the function should show
when the condition is true. The third part is what the function should show when
the condition is false. You can summarize this: =If(condition, if true, if false). The
semicolon (,) is used to separate the various parameters of the function. That's
also true for every other function in Excel.

Ex: =If(B1>=10,b3*0,1,0) If the contents of the B1 cell is superior or equal to
10, show B3's result multiplied by 0,1. Otherwise show zero.

To help you understand how the =If function works, and its potential, the next
part will have some exercises for it. This is the case of a businessman who wants
to offer a discount to its customers if they buy a certain quantity.

Before we begin, open a new worksheet or a file.
Fill the following cells with the text and formulas.

For the first example, the businessman wants to offer a still undetermined
discount if the customer buys 10 identical items or more. This exercise is just to
show whether or not the customer has a right to a discount or not. The result of
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this =If function will only be text, not a number or a formula. Those will come
later.

In the B5 cell, write the following formula: =If(B1>=10,"Discount ","Sorry,
no discount ").

According to the quantity that's entered in the B1 cell, the B6 cell will show
either "Discount" or "Sorry, no discount " (without quotation marks). As
mentioned before, this function has the three parts. In the first part, B1>=10 is
the condition. It verifies that the contents of the B1 cell is superior or equal to
10. If true, the function shows the second part of the function (Discount).
Otherwise, it shows the third part (Sorry, no discount). The result of this function
is posted as text. The next function will have for result a formula or a number.

Enter different amounts in the B1 cell to see how the B5 cell reacts.

The businessman has decided to offer a 10 % discount to those who buy 10
identical items or more. The next formula will calculate this discount.

In the B6 cell, enter the following formula: =If(B1>=10,b3*0.1,0).

For this formula, the condition is the same that the previous formula.
Nevertheless, the result is different. The discount will change according to the
quantity in the B1 cell. If the quantity equals or higher than 10, there will be a 10
% discount on the total in the B3 cell. Otherwise, there is no discount. So, the
number will be zero ( 0 ).

Enter different amounts in the B1 cell to see how the B6 cell reacts.

The third exercise consists of seeing the =If functions been linked. It's possible to
have if() functions inside a =If () function. In fact, it's possible to have functions
in functions. For example, =abs(sum(B1:B200)) gives you the absolute number
of the sum of B1 to B200 cells. It's possible to imbricate up to six if() inside each
other. The next exercise gives you the example of this.

The businessman notices that his discount does not make any sense to most
clients. They don't buy that many. He then offers a 5 % discount to those who
buy 5 identical items or more. He also wants to give a 10 % discount if a
customer buys 10 identical items or more.

In the B7 cell, enter the following formula:
=IF(B1>=10,B3*0.1,IF(B1>=5,B3*0.05,0)).

The function verifies first if the quantity registered in the cell is superior or equal
to 10. If true, the function will show a 10 % discount on the number in the B3
cell. Otherwise, there is the second if() that verifies if the quantity is superior or
equal to 5. If true, it will show a 5 % discount on the number of the B3 cell.
Otherwise, there is no discount. So, the shown number will be of zero ( 0 ).

There is another possible formulation that would have given the same result. =If
(B1>=5,if(B1>=10, b3*0,1,b3*0,05),0). Instead of beginning with the biggest
possibility (>=10) and decent from there, this formula begins with the smallest
possibility (>=5) and rises! There are certainly one or two other formulations that
are possible.
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It's possible to " imbricate" up to 6 levels of Ifs. But at that level, it becomes very
difficult to manage. The =Vlookup and =Hlookup functions will be easier to use
when you have several possibilities.

The function =If () can be improved when it's used with other functions such as
=And() and =Or() . The next part demonstrates the functioning of these two
functions followed of how they can be used with =If().

It's time see them in practice.

Enter numbers and formulas in the appropriate cells.

With these numbers, you should see the "FALSE" in cells B1 and B2. The
numbers don't answer the conditions in either formula. For the = And() function
to work, the cells A1 and A2 must be equal to 1, the necessary conditions for
that function to be true are not yet met. It's the same situation for the =Or()
function.

Enter the number 1 in the A1 cell.

This should bring a change to the =Or() function because one of both conditions
is realized. The B1 cell still shows false because all of the conditions are not yet
met.

Enter the number 1 in the A2 cell.

Because both conditions are now true, the =And() function will now show TRUE.

Enter the number 2 in the A1 cell.

The result was predictable. The B1 cell shows false whereas the B2 cell will still
shows true. If you want, you can add other conditions to these functions. Here is
a small example: =Or(A1=1, A2=1, A3=1). This can go far, very far.

It's possible to add these functions, and many others, in the =If() function. For
these last two functions, it's better place them in the part of the conditions.

=If(and(a1=1,a2=1),1000, 0)
=If(or(a1=1,a2=1),1000, 0)

=Vlookup, =Hlookup

=AND(condition1,
condition2,
condition3...)

A minimum of two conditions is required. But you
can add as many as needed. All the conditions must
be realized for the function to be true. Otherwise, it
will false.

=OR(condition1,
condition2,
condition3...)

A minimum of two conditions is required. You can
add as many as required. One of the conditions must
be realized for the function to be true. If none of the
conditions is realized, it will be false.
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The =Vlookup and =Hlookup functions are forms of the =If function that are a
little more developed. It's possible " to imbricate " up to 6 if functions to answer
several possibilities. But what can you do if you want to answer a question that
needs more than 6 levels? At that level, it becomes difficult to manage every
imbricated =Ifs.

It's easier at that point to use a Vlookup or Hlookup function especially when you
have a grid or a comparison table ready to use. For example, using a grid to
determine a student's grade or the grid to determine the tax rate of the
employees. The Vlookup function uses a vertical comparison table were a Hlookup
function uses a horizontal grid.

Let's resume the last exercise of the =If function. A businessman gives a 5 %
discount to customers who buy 5 of the same item or more. The discount is
raised to 10 % if the customer buys 10 or more.

Using the =If function, the formula may look like this: =If(B1>=10, b3*0.1, if
(B1>=5, b3*0.05, 0)). This formula is simple because it has only three
possibilities (10 and above, between 5 and 10 and between 0 and 5). The formula
becomes more difficult to create when you add more and more possibilities. The
function =Vlookup or =Hlookup can help in this situation.

These functions need three parameters to work. The first one is the cell address
that will be compared to a grid or a comparison table. It will be compared with
the contents of the second parameter that will contain the address of the range of
cells of a comparison table. The third parameter is to indicate the column (for
=Vlookup) or the line (for =Hlookup) that will be shown from the comparison
table.

=Vlookup(cell to compare, comparison table, index of the column)
=Hlookup(cell to compare, comparison table, index of the line)

Before using the function, you must prepare a comparison table.

Enter the following numbers in the appropriate cells, or in the A13 to B15 cells.

The first column of the comparison table is used to compare with a cell that
contains a number. The numbers of that first column must always be in ascending
order. You always put in the lowest possible number, or the floor, to reach this
level. The "ceiling" is the "floor" of the next line of the comparison table. So, for
the first line of the table, the minimal number is zero whereas the maximum is 5
exclusive or [0 , 5[ for those that remember their mathematical operations. It's
as for that reason that the numbers should always be in increasing order.

So, for the table in the A11 to B13 cells, the number 0 of the A13 cell is the
floor. The ceiling is the contents of the A12 cell, or 5. So for all numbers between
0 and up but not including 5 ([0 , 5[) will be on the first line of the table. It's
infinitely close to 5 but it's not 5. All that's between 5 and infinitely close to 10
([5 , 10[) will be on the second line. For the numbers equal or superior to 10, it
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will be the third line of the table. Because there are no other lines over the 10 of
the A13 cell, the "ceiling" is infinite.

The second, the third and the other columns usually contain the results that you
want to show. For this table, the second column contains the discount rates
according to the quantity that was bought.

In the B8 cell, enter the following formula: =Vlookup(B1,A11:B13,2)*B3.

According to the quantity that entered the B1 cell, the =Vlookup function will
compare this amount to its comparison table. When it will know the line to stop, it
can then show the appropriate content from the chosen column. For example, if
the number is 6,5, the =Vlookup function will stop at the second line of the table
(between 5 and 10). It will then show the contents of the second column of this
line witch is 5 %.

To help you to understand, here is another exercise with a grid for school grades.
This exercise consists at showing the appropriate letter for a given note in the B2
cell according to the grade located in the B1 cell.

Enter the text and the following numbers in the appropriate cells.

The B1 cell will contain the number of the grade. The B2 cell will contain the
=Vlookup function that will compare the number in the B1 cell and will show a
letter that's the equivalent to the grade. The B3 cell will contain a =Vlookup
function that will compare the grade with the comparison table and show the
appropriate comment. The A5 to B9 cells contain the comparison table. The table
indicates that the letter will be an " e " if you have a grade below 50. Between 50
and 60, the grade will be a " d ". Between 60 and 75, the grade will be a" c ".
Between 75 and 85, the grade will be a" b ". And, for a grade of 85 or more, the
grade will an " a ". For the =Vlookup function to work correctly, it needs three
parameters: the cell address to compare (B1), the place of the comparison table
( A4:B8) and the column to be shown with the result (the second column or 2)

In the B2 cell, write the following formula: =Vlookup(B1,A4:B8,2).
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You can also copy the formula into the G3 to G6 cells to find the grades noted in
the F3 to F6 cells. Don't forget to "fix" the position of the comparison table by
placing a "$" in front of the lines in the formula. Or else the formula will not work.

You'll learn more about copying formulas and relative and absolute reference
on the next Chapter.

We will continue with something more difficult for the =Vlookup function. It
consists in using the =Vlookup function with two variables. The first variable is
identical to what you saw previously. The second variable consists of changing
the comparison table column that in witch the function fetches the information to
be shown.

Can you write the appropriate formula for the H2 cell? Write the formula that will
show the comment in the H2 cell.

Up until now, you always wrote the number 2 for the third parameter of the
=Vlookup function. The function always fetched the information to be shown in
the second column of the comparison table. The next exercise consists in
changing in the number in that column so that the =Vlookup function fetches the
information to be shown according to the type of customer. That will be the
second variable for this function. For this exercise, there are three categories of
customers: type 1 , 2 and 3. The function should look for the information to be
shown in the second, third or fourth column of the table, depending on the type
of customer + 1 because the first column of the table is used to compare the
quantities bought in the comparison table to determine the quantity of the
discount.

Write the following numbers in the appropriate cells.

And

You now have a new comparison table that takes into consideration the quantities
bought and the type of client. The percentage of the discount will vary depending
on the quantity and the type of client. The D1 cell is also important because it
now defines the type of client being served.

In the B9 cell, write the following formula: =Vlookup(B1,A16:D18,E1+1).

Try the following combinations of numbers in B1 and D1 cells.



Dr. RACHINI Ali – Microsoft Excel – Functions

52 | 2 0 7

B1 E1 Result

4 1 0 %

7 1 2.5 %

7 2 5 %

7 3 7.5 %

10 3
12.5
%

-5 1 N/A

10 4 *REF!

All the numbers work except for the last two cases. In the first case, the amount
bought is a negative quantity, this amount is smaller than the minimal threshold
of the first line of the comparison table ( 0 ). So, this number does not apply to
the comparison table.

For the last case, the function tries to look for information that's outside of the
comparison table. The table consists of four columns. But, the =Vlookup function
looks for information in the Fifth Column, there is no data there.

To make the =Vlookup or =Hlookup function even more powerful, it's also
possible to use it to compare text. The first column of the comparison table can
contain words instead of numbers. As for numbers, the list must be in ascending
order. Contrary to numbers, the text should be exact. For example, the text can
not be between Anjou and Avignon. Otherwise, you should expect the bizarre
results as you'll see below.

Enter the text, the numbers and the following formulas in the appropriate cells.
In the B1 cell, enter Avignon.

The result will be 83 % in the B2 cell. You should expect in bizarre results when
you use text. Let's look at other possibilities.

Enter Tokyo in the B1 cell.

The result will be 99 %! Why? That's because it's listed after Paris. So, the
function goes to the last line of the comparison table.

In the B1 cell, enter Boston.

The result of the B2 cell will be 74 % because it's between Bern and Brussels. So,
although the function is very practical to compare numbers, it may not be as
appropriate for text unless you use the fourth pamateter. The fourth parameter of
this function is used to determine if the function sould look for an exact value to
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compare or be between two values. By default or when the fourth paramater
equals 1, the function is comparing between numbers. When its value is 0, the
function will look for an exact match.

In the B2 cell, entrer the following formula: =VLOOKUP(B1,A4:B7,2,0)

The function will give you a "Not applicable" (#N/A) result because it's now
looking for an exact value and not finding it. Boston is not in the comparason
table.
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Copy, Paste and references

Introduction

To effectively use a spreadsheet, you must be able to create formulas to calculate
automatically any change that you could bring to your model. Because some of
these formulas are alike, it's very effectient to copy them than to rewrite them.
This page demonstrates how to copy formulas and also looks at the very
important point of relative and absolute references. You must master these
notions to properly use a spreadsheet.

Copy

One of the big advantages of a spreadsheet is to be able to copy a formula or a
text as often as you need to create a model. It's easier and faster to copy a
formula than to rewrite it every time you need it. The usual way to copy a cell or
a range of cells is as follows.

Select the cell or the range of cells to be copied.

From the Edit menu, select the Copy option.
OR

Press the button.
OR

Press the Ctrl and C keys

Move the cursor in the cell you want to copy the content or make a range of
cells where you want to copy the formula.

From the Edit menu, select the Paste option.
OR

Press the button.
OR

Press the Ctrl and V keys.

Another technique to copy is to use the fill handle located in the lower right
corner of the cell or a range of selected cells.

You need to:

Place the cursor in the cell to be copied.
Place the cursor on the small black square in the lower right corner of the cell.
Press the left mouse button and move the cursor to the right.

The contents of the cell are going to be copied into the selected cells. You can
also copy the contents in any direction: left, right, up or down. You can also copy
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a range of cells at the same time. The result will vary as the contents of cells are
numbers or formulas. There is an exercise on this option later on this page.

Absolute and relative reference: IMPORTANT

Coping formulas is the fastest way to create a model. There is however a trap
that you must be aware. Let's place the following formula =A1+A2 in the A3 cell.
If you copy this formula in the B3 and C3 cells, the result would be the following:
B3: =B1+B2 , C3: =C1+C2. Why did Excel not copy exactly the formula
=A1+A2?

Actually, it did copy the formula. It's all in the way that Excel interprets the
formula. It's not the cell's address that's important but its position with regards to
the cells where the formula is located. If the formula is in the A3 cell, Excel will
interpret the formula =A1+A2 this way: the A1 cell is two cells above the current
position of the formula and A2 cell is just above. So, when Excel will copy the
formula it's going to add both cells just above where the formula is placed. It's for
that reason that the formulas copied in the B3 (=B1+B2) and C3 (=C1+C2) cells
are this way. They also add the numbers of the two cells above the formula. This
kind of reference in the formula is called relative reference. Everything is relative
to the location of the formula. Excel always fetches the numbers in the same way.
It's also more practical when you copy a formula. You usually use the same
formula on a different set of numbers. For example, you can copy a formula that
adds the monthly expenses. The same formula that was needed for January
should also work for every other month of the year.

Quiz: If you copy the formula =A1+A2 from the A3 cell to the Z20 cell, what will

the formula look like? The answer is at the end of this page.

But what can you do when you need a variable in the formula? A variable is
information that can change at any time. For example, if you want to know what
happens to the profits if the growth rate changes from 5 % to 50 %. Or what if
the number of employees passes from 5 to 25? Or what if the mortgage rate to
be renewed changes?

A model consists of three elements: constants, variables and formulas.
Constants are number needed to start your model. They will not change during
the timeline of your model. Even these numbers change in the long run, but not
in the time frame for this model. Examples of constants are tax and insurance
rates, sales tax, telephone bill and mortgage payments.

Variables are the data that you want to test the model by asking " what happens
if... " questions. What will happen if the interest rates rise? What will happen if a
customer doesn't pay? What will happen at such a growth rate? These variables
can change at any time so that you can try to find the best solutions for your
model.

Never write a variable in a formula. For example, never write =100000*10%.
Otherwise, you'll have to change every formula each time the variable changes.
It's for that reason that you need to place a variable in a single cell. If the
variable is written in several cells, chances are you are going to forget to change
a value in one of these cells. This would invalidate your entire model because you
forgot to change a single value. It also makes it very difficult to make sure that
the model is correct because you must verify all the cells or where the variable is
located. This would make the validation process, very long and very painful. So,
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it's better to avoid copying a variable in several places in a file. The best way is to
write a variable in a single cell and have every formula refer to that cell. Change
the content of a single cell and your entire model changes! Isn't it why you
created a model in the first place?

This makes the work of creating formulas a little more complicated. What must
you do when you want to copy a formula? Cell addresses are composed of two
components: a reference to the column and to line they're located. The first cell's
address, A1, is composed of these two components. The letter represents the
column and the number represents the line. The column's addresses are from A
to Z and then from AA to IV (in Excel 2007 it goes up to XFD). The line's
addresses are from 1 to 65 565 (compared to Excel 2007's 1 048 576).

By copying a formula, the relative reference changes too. The column reference
changes when you copy a formula horizontaly (left to right). The line reference
changes when you copy a formula verticaly (up and down).

You can use the dollar sign ($) to "fix" or "freeze" a column or a line in a formula.
When the formula will be copied, the parts that are frozen will not change. To
freeze, you must place the dollar sign ($) in front of the column or line position.

Exampl
e:

Write
number
s and

following formula in the appropriate cells.
A1: 100 , A2: 200 , A3: =$A1+A2

Copy the contents of the A3 cell in the B3 to E3 cells. There are many ways to
copy the formula. Here are two of them

Place the cursor in the A3 cell.
From the Edit menu, select the Copy option.
Make a range with the B3 to E3 cells.
From the Edit menu, select the Paste option

There is also the other way by using the fill handle.

Place the cursor in the A3 cell.
Place the cursor on the lower right corner of the cell, on the black square in the

corner. The shape of the cursor should change to a black "+" sign.
Keep your finger on the left mouse button and move the cursor up to the E3

cell.

The other ways would have been to use the CTRL+C and CTRL+V keys to copy
and paste the cell. You could also have used the copy and paste buttons on the
standard toolbar or use the copy and paste options from the context menu that's
available by pressing the right mouse button.

The formulas in the B3 to E3 cells are:

Cell Result Formula

B3 100 =$A1+B2

A1 Neither the column nor the line is frozen.

$A1 The column is frozen but not the line.

A$1 The line is frozen but not the column.

$A$1 The line and the column are frozen.
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C3 100 =$A1+C2

D3 100 =$A1+D2

E3 100 =$A1+E2

By "freezing" the A column in the formula, this reference will always look for the
value in the first column (A). This is necessary when you want to look for the
contents of a cell that contains a variable and you wish to copy the formula. A
formula that has a relative position would not allow you to look for the contents of
the A1 cell once it's copied elsewhere. By freezing the column or the line in the
formula, you'll not be obliged to change the formula once you copied it to other
cells.

If you want to copy a formula horizontally, you may only need to freeze the
column reference ($A1). If you wish to copy a formula vertically, you may need
to freeze the row or line reference (A$1). If you a coping the formula to a
different row and column, you may need to freeze both. It depends on where the
data is located relative to the position of your formula. If they're always in the
same cell, you need to freeze the column of line to get an absolute reference.
Excel will always look for the data in the same column or line.

Exercise with the exchange rate

This exercise is to demonstrate the enormous advantage of using relative and
absolute references in formulas that you want to copy. It consists in changing the
values of US currency into Canadian dollars.

Write numbers and formulas in the appropriate cells.

For this exercise, we presume that 1 US dollar equals 1.4 Canadian dollars, which
is a the rate in the A2 cell. The A3 cell contains the formula that will help us to
find the value for the first column. The result of this cell should be 7 (5 * 1.4 =
7). You could write the formula again for the following cells, from B3 to D3, but
it's even more effective to copy the formula to the other cells (B3 to D3).

Place the cursor in the A3 cell.
From the Edit menu, select the Copy option.

OR

Press the button.
OR

Press the CTRL and C keys.

The frame around the A3 cell will flash. This is normal. It's to remind you that it's
the cell that you have just copied.

Make a range with the B3 to D3 cells.
From the Edit menu, select the Paste option.

OR
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Press the button.
OR

Press the CTRL and V keys.

And here it is! The formula is now copied in the other cells that you have just
specified. However, the result is not what you expected. There are only zeros
instead of values! Let's find out why.

Place the cursor in the B3 cell.

You can see from the formula bar the following contents:

You'll notice that the B1 cell contains a value ( 10 ) whereas the B2 cell is empty.
It's for that reason that Excel shows the value 0 (10 * 0 = 0) in the B3 cell.

To solve this small problem, you could copy the exchange rate of the A2 cell in
the B2 to D2 cells. But that's not a practical solution for several reasons. In the
first place, the same value would occupy several cells for nothing. You could put
the other numbers or formulas in that place. Secondly, the chances to forget to
change the contents of a single cell during modifications are far too high. It would
be really pity to have a useless model because you forgot to change the contents
of one or two cells!

It's preferable to put the values of variables and constants in cells apart and
adjust formulas. It's never a good idea to put the value of a constant or a
variable in a formula. As mentioned in the previous paragraph, if you forget to
change the value in a single cell, invalidates your model.

In fact constants and variables have something common: they can change. A
variable can change any time for the needs of your model: occupation rate, price
of a product, price of the material etc. A constant can also change but on a mid to
long-term basis: taxes, tax rates, interest rates... Because a variable or constant
can change, it's much easier to manage it by placing the value in a single cell.
You can adjust your formulas to refer to that cell using relative and absolute
references. You must master theses references if you wish to copy formulas and
efficiently use Excel or any other spreadsheet.

Let's return to the exercise. The formula must be adjusted so that it can always
find the exchange rate in the right cell; A2 in our case. But what must you know
before adjusting the formula?

Is there a part of the formula that you want to fix or freeze? For the exercise, it's
necessary to "fix" the A2 part of the formula.

You must know if you will copy the formula horizontally, vertically or both? For
the exercise, the formula will be copied horizontally in the B3 to D3 cells.
Because it's horizontally, you only need "freeze" or to "fix" the letter of the
column and not the number of the line in the cell address contained in the
formula.

It's now time to change the formula of the A3 cell to adapt it.
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Place the cursor in the A3 cell.

To change the contents of the cell.

Press the F2 key.
OR

Double-click the A3 cell.
OR

Place then the cursor on the formula bar.

Change the contents of the formula to this: =A1*$A2

The formula was changed but the value remains the same: 7 (5 * 1,4). It's only
when you'll copy the formula and see the results that you'll notice the change.

Copy the formula in the A3 cell into the B3 to D3 cells.

If you need a reminder, refer to the instructions for copying above.

Verify the formulas of in the B3 to D3 cells.

B3: =B1*$A2
C3: =C1*$A2
D3: =D1*$A2

You have now the right result because you "froze" the A column of the A2 cell.
Look how it's practical:

Change the value of the A2 cell from 1.4 to 1.25.

All the values in worksheet have been changed by changing the content of a
single cell! What do you prefer now; change the contents of a single cell or
change several cells? Which one is the most efficient? (Answer: change a single
cell)

But it's necessary to pay attention in the way that one uses the relative and
absolute references.

Place the cursor in the A3 cell.
Copy the contents of the cell.
Paste it in the A4 to A8 cells.
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What exchange rate! Let's verify the contents of the A4 to A8 cells.

A4: = A2*$A3
A5: =A3*$A4
A6: =A4*$A5
A7: =A5*$A6
A8: =A6*$A7

You see the problem! The formula was copied vertically and not horizontally.
Although the column is frozen, the lines are not. It's for that reason that the
results climb so quickly. Be careful when you apply relative and absolute
references. Be sure to freeze the right column or line.

Please.
Take as much practice as you can with this technique. It's essential to effectively
use Excel. Build your own exercises!

The answer to the relative question about copying the formula =a1+a2 from the
A3 cell to the Z20 cell is: =Z18+Z19. It adds the content of the two cells just
above the formula, wherever it's located in the worksheet.
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Charts (Graphs)

Introduction

Why use a chart?

To simplify the analysis of a mass of data.
To be able to compare the data.
To quickly analyze the trends in data series.
To analyze proportions among different data series.

Create a chart

This exercise consists in creating a "3D Column chart" on a new worksheet.

Enter the following data in the appropriate cells.

Select the data by using a block (continuous or non-continuous), for the
exercise, from A1 to D4.

The data selection is very important. Avoid selecting empty lines or columns.
They will be added to the chart and leave empty spots in your chart. Use the

instructions in the Basic operations page to select only the blocks of cells that
you need. Make sure that every range of cells selected represents at least a data
series for the chart. Don't take single cells scattered everywhere on your
worksheet.

Generally, the first line or row selected from the range of cells will be used by the
chart for the description of the X axis. The content of the first column from the
range of cells will be used as the description for the legend of the chart. But,
Excel will be confused if the description that you need for the X axis are numbers.

From the Insert menu, select the Chart option.
OR

Use Excel's chart assistant by pressing the button.
Answer the questions that you will be shown in the next windows.
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The first stage consists in choosing a chart from the 14 categories that are
represented in the left column. In the right part of the screen, there are
subcategories to represent the same data in a different ways.

These subcategories are alike, but will give a different representation from the
same data. The first line shows the data in two dimensions (2D). The second line
shows these same data but in three dimensions (3D). Furthermore, the first
column shows the data series the one next to another. The second column shows
the data series in cumulative mode (one on top of the other). The last column
shows the proportion of each of the series. Notice that each of the bars is of the
same height, only the proportion of each series changes.

Before continuing, it's possible to have a preview of the chart to make sure to
have chosen the right type of chart to better to represent the data. Press the
button "Press and Hold to View Sample" to have a preview of the chart. The
section with the subcategories of chart will be replaced by a representation of the
chart. You can try different types of charts before going any further and preview
them.

Make you have the right selection. For the exercise, select from the Column
charts, the 3-D Column option.

Press the Next button.

For the second step to create a chart has two tabs: the one to determine the
range of data (Data range) and the other to look of the data series.



Dr. RACHINI Ali – Microsoft Excel – Charts

64 | 2 0 7

The Data range tab is there to make sure that you chose the right area of cells
as the data series of your chart. If there is an error, you can always press the
button at the end of the box to re-select the cells you need for the chart. You can
determine that the data series are in columns or in lines. This means that every
line or every column represent a data series on an item that you want to
represent in the chart. For the purpose of this exercise, make sure that the data
series are in rows and not in columns. That means that every row from the range
of cells you selected will be a data series.

You also have a preview of the final chart before having finished it! You can
experiment and see that will be the final result by changing the representation of
the data series.
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Click on the Series tab.

Under the Series tab, it's possible to change, add or delete data series. In the
bottom to the left of the window, you have the name of each of the series. In the
right-hand side, the "Name" box allows you to change the name of a series. It's
that name that will appear in the legend of the chart. You can select the content
of a cell of one of the worksheets of the file or you can write the text of your
choice.

The "Values" box is an area of cells that contain the numbers you want to see in
the chart for that data series. You can change the area at any time.

The "Category (X) axis labels" box indicates the description that will be shown on
the X axis of the chart. It's still possible to you to change it. You just need to
press the button at the end of the box and select the cells that you wish for the X
axis. You can also write the content. You need to place a semi-colon (;) between
the text For example, orders could come from "In store";"Catalogue";"Internet".

Make your selection and press the Next button.

For the third step, there are several tabs. Each describes a characteristic of the
chart.
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Click on the Titles tab.

The tab of the titles serves for writing the text that will appear to the main title of
the chart as well as for the descriptions of each of the axes of the chart. For this
exercise:

In the Chart title box, write: Revenues by Categories.
In the Category (X) axis box, write: Years.
In the Series (Y) axis box, write: Categories.
In the Value (Z) axis box, write (M$).

Click on the Axes tab.

The Axes
tab gives
you the
choice to
show or
to hide
the data
of the
various
axes of
the chart.
For the
moment,
leave all
axis
visible.
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Click on the Gridlines tab.

Gridlines help you compare items that are not close to each other. You compare
them to the gridlines to see a trend upward or downward. Under this tab, it's
possible to show or hide the gridlines of the chart. For the purpose of this
exercise, select the same options as the image; just activate the major gridlines
for each axis.

Click on the Legend tab.

This tab allows you to show or not the legend of the chart. It contains the names
of each series of your chart with a color representation beside it. There, more you
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can decide on the position of the legend.

Select the Bottom position.

Click on the Data Labels tab.

Under this tab, it's possible to you to show labels and values of each of the
elements of the series. You can show the value, the percentage, both or even the
description of the X axis (series name). The big problem with this option is that it
crowds the chart with too much information making it more difficult to read. One
option is to activate the label you want but move them on the side of the bar
instead of over the top of each bar. It gives more information without blocking
the view on the trends or the proportions of the chart.

For this exercise, do not activate any options.
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Click on the Data Labels tab.

This is a recent addition to Excel. It's possible not only to show a chart but also
the numbers themselves in a table below the chart. Select the Show the data
table option to have a preview of the result. However, for the needs of the
exercise, don't show the data table. It will be shown how to show this table, and
how to personalize the chart farther on this page.

For this exercise, do not activate the Data table.
Press the Next button.

The chart assistant will ask you a last question. Do you want this chart in a
worksheet that has numbers or on a new chart sheet? You can also give a name
to this new working sheet.

For this exercise, select a new chart sheet that will be called Chart1.

Press the Finish button.

Excel will show you the finished chart with the options you selected.
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Personalize the chart

Even if you finished the chart, it's always possible to personalize it better to
answer your needs. The next part consists in showing to you some of its options
and how to apply them.

The first stage consists in widening the space that's assigned to the chart.

Click on the chart only to select the part that's reserved for the chart.
Select one of the squares dimension square on the border of the chart.
Press the left mouse button and move the dimension square to the outside of

the zone reserved for the chart.

You can, by selecting an object, that it's the chart, the title, the legend or quite
other object that meets itself in the zone of chart, to move it or to change it.

The chart changed dimensions. But, the text that meets itself on axes is still too
big for the rest of the chart. To change the size of the text, there are three ways.

Place the cursor on the X axis of the chart.
Double-click on the axis.

OR
Click on the X axis.
From the Format menu, select the first option;

OR
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From the chart toolbar, select the Category axis from the list on controls on the
chart.

Press on the Properties button .

The window with the properties of the axis will appear

Change the size of the text to 10 points.
Repeat the operation for the "Y" and "Z" axis.

It may be necessary to enlarge the size of the font for the title of the chart.

Double-click on the title of the chart.
Select all the text of the title.
Change the size of the text.

The result should look like the image below.
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This looks like a chart that you can put in a report or a document for a customer
or even to your boss. But you can even better. Excel offers several other options
to improve the presentation of a chart.

Changing options

To change an option of one of the objects in the chart, you can click on it and
choose from the Format menu the first option. You can also double-click on the
object that you want to change. Another way is to click the object and to press
Properties button on the Chart toolbar. Another option you can use is by placing
the cursor over the object and pressing on the right mouse button. A list of the
options most often used will appear. It is also called a context menu.

Here is the short list of what you can make to change in the chart: move objects,
change their size, the color and the orientation of the text, change the color, the
pattern and the order of the series, insert some free text, drawings, arrows, the
square or any item from the Draw toolbar, etc. You can access all the options by
using the mouse or the main menu.

To stop changing options of the chart, click outside of the frame of the chart. If
you generated your chart on another worksheet, click the tab to another
worksheet.

Change the legend's text

It's also possible for you to change the text that's in the legend. Here is the
legend before the change.

From the Chart menu, select the Source data option.
Click on the Data Range tab.
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Under this tab, you
can change the
area of the data
and change the
data series of lines
in columns or vice
versa.
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Click on the Series tab.

Under this tab, you can add or remove data series to the chart. It's also possible
to change the name of a data series that appears in the legend, to change the
range where the values are located and the description for the X axis of the chart.
This exercise consists in changing the name that seems to the legend for the
series "Other".

From the Series section, select the Other option .

The data about the series will appear in the boxes to the right of the window.

Click in the Name box.

You can write of the text or write the name of the cell that will be the description
of the legend.

Write Small items.
Press the OK button.

Here is the legend after the change.
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Change the legend's placement or position

There are three ways to change the place: by using an option of the format menu
or the properties of the chart or manually by using the mouse.

Click on the legend.
From the Format menu, select the first option: selected legend.

OR
From the Chart toolbar, select the object Legend of the list.
Press the button of the properties.

Click on the Position tab.
Select the new location for the legend in the chart.

You can also move the legend by using the mouse.

Click on the legend
Place the cursor inside the legend box.
Press the left mouse button and move the box down to the bottom of the

chart.

You can later change the size of the chart to take advantage of the space freed by
the legend.

Click on the chart.

A border with squares should appear around the chart. Otherwise, re-select.

Place the cursor on the square of the middle right border of the chart.
Press the left mouse button and move the square to the right-hand side of the

screen.
Release the mouse button.

You can so in this way by using the other squares to change the size of the chart.

Change the size, the color and the orientation of the text

It's possible to change these options for all the boxes of text including the one on
the axes.

Click on the main title.
From the Format menu, select the first option: selected title.

OR
Double-click on the main title.

Select the Font tab.
Change the options of size and color in your choice.

The next example consists in changing the orientation of the text of one of axes...

Double-click on one of the axes.
OR

Click one of the axes of the chart.
From the Format menu, select the first option: selected axis.
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Click on the Position tab.
Change the vertical orientation of the text.
Press the OK button.

Change the color and the shade of bars

To highlight a data series, it's possible to change its color as well as its pattern.
Furthermore, if you think of printing on a printer, you may need to change the
pattern for each of the series. Otherwise, the bars of the chart are all going to
look the same. For example, a data series of the red color will be printed with the
same tone of grey as the one that's blue. Both are going to be printed grey on a
piece of paper. It may be better to distinguishing different data series to have a
different pattern for each.

Click on one of the data series.
From the Format menu, select the first option: Selected Data Series.
Click on the Patterns tab.

Press the Fill Effects button.



Dr. RACHINI Ali – Microsoft Excel – Charts

77 | 2 0 7

There are many ways to change the pattern on the bars of a Data series. Excel
regroups them under four tabs: Gradient, Texture, Pattern and Picture. The
Gradient tab able you to place gradient progressive patterns on the bars. The
Texture tabs able you to place "natural" pattern from marble, wood and fabrics.
The Pattern tab offers different types of stripes, lines and other regular patterns.
The Picture tab offers you the possibility to apply an image of your choice inside
the Data series bar. Look at all the options and select the one that you need.

Change the color and the pattern for the Data series.
Select the Shape tab.
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Not only can you change the patterns on the bars of the chart, you can also
change the forms. You can choose from regular boxes to pyramids, cylinders and
cones. Please take note that the only fill effects available for cylinders and cones
are patterns, no gradient, texture or images for them.

Select the Pyramid type.
Press the OK button.

Change the series' order

From time to time, a data series is hidden by the others. Or you may wish to
move a data series ahead of another. It's possible for you to change the order of
the data series to avoid this situation.

Click on the series that you want to change the place in the chart.
From the Format menu, select the first option Selected Data Series.
Click on the Series order tab.
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Select the series of your choice from the left column.
Press the "Move up" or "Move down" button according to your choice.
Once finished, press the OK button.

The more the data series is up on the list, the more toward the front of the chart
it will be. Here is the result according to the order of the previous image.
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Replace the series in its original location in the chart.

The data labels

You can show the value of the bar or the description of the axis of the various
data series.

Click on the first data series.
From the menu Format, select the first option: selected data series.
Click on the Data labels tab.
Press the radio button next to the Show value option.
Press the OK button.

The values that represent bars are going to appear above these. You can then
move them towards your choice. This option shows you the values of a series at
the same moment. It's possible to show the labels of all the series.

From the Chart menu, select the Chart Options option.
Select the Data labels tab.
Select the Show values option.
Press the OK button.

The values of the series appear above bars. You can move them afterward and
change their format.

Remove all labels.

Insert an images

It's also possible to add images such as the company logo or another image
suited for the chart.
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From the Insert menu, select the Image option.

Excel offers you several sources for the image. It can be from Office's library, the
Internet, a file that you have or a WordArt text image.

Select the From a file option.
Select the right drive (Hard disk, CD, diskette ...) and the right folder.
Click on the name of the file.
Press the OK button.

To move the image.

Place the cursor inside the image.
Press the left mouse button, keep pressing it and move the image in its new

location.

To change the size of the image.

Click on the image.

A border with squares will appear around the image.

Place the cursor on one of the square of your choice.
Press the left mouse button and move the square to enlarge or reduce the size

of the image.

To keep the image size proportional, also keep a finger on the Shift key.

Insert free text

Apart from the main title and the axes titles, it's also possible to add text to the
chart to add comments.

Click on the formula toolbar.
Write Spectacular increase! and press the Enter key or the button with the

green checkmark.

The text will appear in the chart. To move the text box.

Place the cursor inside the text box.
Press the left mouse button and move the text box in the right-hand side of the

chart.
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You can then change the format of the text such as its size, its color and its
orientation. Simply select the text and to choose the first option from the Format
menu or double-click on the text.

Insert an arrow

Not only can you add text but also any object from the Draw toolbar. The next
exercise consists in adding an arrow to the chart to better explain a point. It's
also possible to add square, circles and several other objects. Before, continuing
the Draw toolbar must be activated.

From the View menu, select the Toolbars.
Activate the Drawing toolbar by placing.

To move the Drawing toolbar.

Place the cursor on the titles bar of the toolbar.
Press the left mouse button, keep pressing it and move the bar completely to

the bottom of the screen.
Release the mouse button.

To insert an arrow.

Click on the button arrows.
Place the just cursor below the text "Spectacular increase!"
Press the left mouse button and move the cursor up to the third bar of the first

data series.
Release the mouse button.
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Add a series of numbers

Your are now asked to add a data series that includes the exports of the
company.

Add this last data series of numbers to your model.

In fact, it would have been able to place these data wherever on the worksheet.
It's only the most logical place to place them. There are two ways to insert them:
by using the options of for chart or simply to "drag" the range over the chart. The
next part consists in adding a data series by using the options for charts.

Click on the chart.
From the Chart menu, select the Source Data option.
Click on the Series tab.
Press the Add button.

You'll have to enter some data in the Name and Values boxes so that the new
Data series shows up on the chart.
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Click in the Name box.
Write in the Exports box.

OR

Press the button at the end of the box.
Select the cell containing the text Exports.
Press the button at the end of the window.

Click in the Values box.

Press the button at the end of the box.
( 5 , 10 , 20) select the data series for the exports (B5 to D5).
Press the button at the end of the window.

Because labels for the X axis are the same than for the previous series, you
don't need to change the data.

Press the OK button.

A new data series was added to the chart. This series is however in the back of

the chart. It's hidden by all the others. You can change the order of
presentation of the series that was explained earlier on this page.
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The other way of adding a data series to the chart is to select the range of values
and the title (A5 to D5) and to slide it over the chart. However, this option works
only if the data and the chart are on the same worksheet. This is impossible for
the exercise of this page. The procedure is very simple.

Select the area of data including the title.
Press the left mouse button and move the selection over the chart.

Once over the chart, the cursor should change and show a "+" sign next to the
cursor.

Release the mouse button.

The selected series will appear on the chart.

Insert a second Y axis

Excel makes possible the addition of a second Y axis on the right-hand side of the
chart. This allows you to compare values of different proportions. For example, it
would be very difficult to compare millions of units sold to the percentage of
market shares. This option is only available for charts with two dimensions (2D).
Before demonstrating you this option, it will so be necessary to change type of
chart.

Remove the ''Spectacular increase'' text and the arrow.

From the Chart menu, select the Type of chart option.
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Select the type of chart according to the image above.
Press the OK button.

For this exercise, we are going to presume that the data series Exports needs to
be on a second axis.

Select the series Exports by clicking one of the bars of the series.

Be careful!
All the bars of the series should be selected. Otherwise, click somewhere else the
chart and select once again the Exports series.

From the Format menu, select the option Selected Data Series.
OR

Double-click on the series.
OR

From the chart toolbar, select the item Series "Exports".

Press then on the button.

Select the Selected Data Series tab.
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Activate the Secondary Axis option.

Excel offers you a preview of the chart. You can change this option or the others
concerning the data series.

Press the OK button.
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The Export data series is now visible beside the other date series of the chart. It
has its own Y axis on the right-hand side of the chart.

To be able to better compare the data series Exports of the others, it would be
preferable to change the type of chart for it. It will be changed the type of Line
chart.

Select the Exports series with one of the techniques mentioned above.

Select the type of chart for only this Data series by selecting a Line with
markers for the type of chart.

Press the OK button.
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Here is the chart under its final format. It's now easier to distinguish the series
and to compare them. There was also another way of changing the type of chart
for one or all the data series. But you can't mix 2D with 3D charts or some types
of chart with others.

Select the data series or the chart in its entirety according to your needs.

From the Chart toolbar, select the type of chart of your choice.

There are some types of predefined charts having two axes.

From the Chart menu, select the Type of chart option.
Select the Custom Types tab.
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Of the list of the types of charts, there are two that have two axes: Line - Column
on 2 axes and Lines on 2 Axes.

Press the Cancel button.

"Explode" a part of a pie chart

The "Pie" charts are mostly used to demonstrate proportions or shares. But you
may wish to highlight a point of the pie to put it more interest on it. Before being
able to "explode" a point, it's necessary to create a pie chart.

Enter the following data in a worksheet.

Make a block with the range of data.

Press the chart button .
From the list of chart types, select Pie.
Select the Pie with a 3-D visual effect option (second option).
Press the Next button twice.
Press the Legend tab.
Unselect the View the legend option.
Press the End button.
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The "3-D Pie chart" will appear in the frame that you created. Otherwise, begin
again the steps above.

Click on the pie.
Click on one of the

parts of the pie.
Place the cursor inside

that part.

Press the left mouse
button, keep pressing it,
and move the part
towards the outside of
the pie.

Release the mouse
button when you'll have
moved the part to the
new location of your
choice.

It's as easy as pie to split a pie chart! Sorry! I couldn't resist the pun.
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Print only a chart

It's always possible to you to print the chart alone on a page even if it's next to
numbers and to formulas.

Click on the chart you wish to print.

All the options of the menus are going to fit to give the possibilities of the chart;
including the printing. If you don't click the chart, the page setup and printing are
going to show you the chart and the numbers of the worksheet instead of only
the chart.

To have a print preview of your chart, press the button.
OR

From the File menu, select the Print Preview option.

You can use the same page setup and printing options as you set for the printing
of the worksheets. Make sure to always preview before the printing. If you want
to print just the chart, trust the preview of the chart. Although the chart seems
correct with your data, it's the print preview that gives the best representation on
to paper.

Press the Setup button.

They are the options of pagination for the chart. They are almost identical to
those for the pagination for the file with the exception of the last tab: chart.

Click on the Chart tab.

The chart size option allows you to determine the size that it will take on paper.
The "Use full page" option ajust the chart to take advantage of the whole page.
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The option "Scale to fit page" takes just advantage of the width of the page. The
"Custom" option keeps the chart the same size as on the worksheet.

The print quality options allow you some control over the chart's printing. The
"Draft quality" option is faster and uses less ink or toner. The "Print in black and
white" option is for dot matrix printers. This helps to make the distinction
between each of the data series of the chart.

The Options... button will show you the available options of the printer. The
contents of these tabs vary according to the type of printer that's available. These
tabs help to :

Determine the paper format as well as the page orientation.
Determine the printing quality, or resolution in dot per inch (dpi), of a chart.
Determine the way that fonts will be printed.
Determine how the memory of the printer will be managed.

Because the contents vary according to the printer, it's up to you to select from
the options that are offered.
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